Discussion:
antispam-razor Problem mit razorreport
(zu alt für eine Antwort)
Dirk Alberti
2020-05-14 11:04:44 UTC
Permalink
Hallo zusammen,


Ich habe seit einiger Zeit ein Problem(chen) mit antispam-razor, was ich
nun gerne in Angriff nehmen möchte.

Auf meinem IMAP-Server habe ich einen Mailordner "Spam-manuell" in dem
ich durchgekommene Spammails verschiebe und woraus antispam-razor diese
"reportet" und dann löscht. So sollte es doch sein, wenn ich den Sinn
des Paketes richtig verstanden habe, oder?

Nun erhalte ich danach immer Mails von Cron mit folgendem Betreff:

fcron <***@eisfair> /var/install/config.d/antispam_razor.sh razorreport

und folgendem Text:

/var/install/config.d/antispam.sh: line 1446: 25288 Segmentation fault /usr/bin/sa-learn ${debuglevel} --${mailtype} --mbox ${boxname} >> ${tmplogname}

Die Mails sind aber dann aus Spam-manuell verschwunden.

Grüße, Dirk
Juergen Edner
2020-05-14 11:36:48 UTC
Permalink
Hallo Dirk,
Post by Dirk Alberti
Auf meinem IMAP-Server habe ich einen Mailordner "Spam-manuell" in dem
ich durchgekommene Spammails verschiebe und woraus antispam-razor diese
"reportet" und dann löscht. So sollte es doch sein, wenn ich den Sinn
des Paketes richtig verstanden habe, oder?
korrekt.
Post by Dirk Alberti
/var/install/config.d/antispam.sh: line 1446: 25288 Segmentation
fault      /usr/bin/sa-learn ${debuglevel} --${mailtype} --mbox
${boxname} >> ${tmplogname}
Bitte entferne einmal in den beiden Skripten das Kommentarzeichen
vor der Debug-Zeile und führe anschließend den Befehl einmal aus.

/var/install/config.d/antispam_razor.sh # Zeile 26
var/install/config.d/antispam.sh # Zeile 37

Befehl: /var/install/config.d/antispam_razor.sh razorreport

Anschließend sende mir bitte die erzeugten Trace-Dateien per PM zu.

Gruß Jürgen
--
Mail: ***@eisfair.org
Loading...