Discussion:
update sane version 2.9.0 testing
(zu alt für eine Antwort)
Holger Bruenjes
2020-05-27 10:20:13 UTC
Permalink
Hallo

Ich habe eine neue Version der SANE-backends 1.0.29 bereitgestellt.
Fuer den Scanbuttond habe ich auch noch einen patch gefunden, somit
will da er nun auch mit der aktuellen libusb-1.0.23


Holger
Stefan Puschek
2020-05-27 11:28:26 UTC
Permalink
Hallo Holger,
...
Post by Holger Bruenjes
Ich habe eine neue Version der SANE-backends 1.0.29 bereitgestellt.
Fuer den Scanbuttond habe ich auch noch einen patch gefunden, somit
will da er nun auch mit der aktuellen libusb-1.0.23
Du hast mein "Kopierer"-Skript gerettet :)

alle Pakete aktualisiert - also keine alten Versionen mehr, dann zur
Sicherheit einen reboot...

der scanbuttond läuft
sane läuft
ich kann im Browser scannen (phpsane ist genial)

getestet mit 'Canon CanoScan N670U/N676U/LiDE20 flatbed scanner'

Vielen Dank für Deine Arbeit!


Groetjes
Stefan
Holger Bruenjes
2020-05-27 13:01:57 UTC
Permalink
Hallo Stefan
Post by Stefan Puschek
alle Pakete aktualisiert - also keine alten Versionen mehr, dann zur
Sicherheit einen reboot...
der scanbuttond läuft
sane läuft
ich kann im Browser scannen (phpsane ist genial)
getestet mit 'Canon CanoScan N670U/N676U/LiDE20 flatbed scanner'
klingt doch schon mal gut ;-)

Holger
Dirk Alberti
2020-06-04 04:21:36 UTC
Permalink
Hallo Stefan,
Post by Stefan Puschek
sane läuft
ich kann im Browser scannen (phpsane ist genial)
weißt Du noch, was Du angepasst hast, um phpSane zum laufen zu bringen? 
Ich vermute bei mir Rechteprobleme entweder bei scanimage oder beim
Zugriff auf USB. Eine ini-Datei hat phpSane schon selber erstellt für
meinen Scanner. Die Webseite an sich funktioniert auch.

Gruß, Dirk
Stefan Puschek
2020-06-04 10:21:37 UTC
Permalink
Hallo Dirk,
Post by Dirk Alberti
Post by Stefan Puschek
sane läuft
ich kann im Browser scannen (phpsane ist genial)
weißt Du noch, was Du angepasst hast, um phpSane zum laufen zu bringen?
Ich vermute bei mir Rechteprobleme entweder bei scanimage oder beim
Zugriff auf USB. Eine ini-Datei hat phpSane schon selber erstellt für
meinen Scanner. Die Webseite an sich funktioniert auch.
das ist JAHRE her - keine Ahnung ob ich damals etwas anpassen musste;

überprüf mal, ob Dein apache überhaupt scanimage ausführen DARF

auf der Webseite von phpsane MUSS rechts oben unter Scanner device Dein
Scanner stehen, dann hat er ihn erkannt - und beim Klick auf Preview
rattert der Scanner...

es gibt auch noch php-scanner-server

https://github.com/GM-Script-Writer-62850/PHP-Scanner-Server/issues

läuft bei mir in V1.5-16

Scanner ist ein Canon LIDE20

Groetjes
Stefan
Stefan Puschek
2020-06-06 10:13:37 UTC
Permalink
Hallo Dirk,
...
Post by Dirk Alberti
weißt Du noch, was Du angepasst hast, um phpSane zum laufen zu
bringen? Ich vermute bei mir Rechteprobleme entweder bei scanimage
oder beim Zugriff auf USB. Eine ini-Datei hat phpSane schon selber
erstellt für meinen Scanner. Die Webseite an sich funktioniert auch.
such mal im Archiv - am 18.04.2015 "sane - Erfolgserlebnis und Frage"
schrieb ich, was ich damals (!!!) ändern musste, damit phpsane mit
meinem Canon Lide 20 lief; so läuft es heute noch...

Groetjes
Stefan
Dirk Alberti
2020-06-06 14:33:39 UTC
Permalink
Hallo Stefan,
Post by Stefan Puschek
Hallo Dirk,
....
Post by Dirk Alberti
weißt Du noch, was Du angepasst hast, um phpSane zum laufen zu
bringen? Ich vermute bei mir Rechteprobleme entweder bei scanimage
oder beim Zugriff auf USB. Eine ini-Datei hat phpSane schon selber
erstellt für meinen Scanner. Die Webseite an sich funktioniert auch.
such mal im Archiv - am 18.04.2015 "sane - Erfolgserlebnis und Frage"
schrieb ich, was ich damals (!!!) ändern musste, damit phpsane mit
meinem Canon Lide 20 lief; so läuft es heute noch...
danke für den Hinweis, aber diese Änderungen hatte ich auch schon
irgendwo anders "erlesen".

Ich habe jetzt allerdings eine Version von phpSane gefunden, bei der es
auch mit meinem Scanner funktioniert.

Hier der Link, der Statistik halber ;-)  :
https://github.com/christopherkobayashi/phpSANE.git
Post by Stefan Puschek
Groetjes
Stefan
Grüße, Dirk

Dirk Alberti
2020-05-28 13:54:04 UTC
Permalink
Hallo Holger,
Post by Holger Bruenjes
Hallo
Ich habe eine neue Version der SANE-backends 1.0.29 bereitgestellt.
mein Problem mit sich vermutlich aufhängendem USB-Port behebt es leider
nicht.
Post by Holger Bruenjes
Holger
Dirk
Loading...